サクラエディタで正規表現が使えない!という場合の方法

いろいろなエディタがあると思いますがみなさんはどのエディタを使っていますか?

僕は最近ではサクラエディタをよく使っています。

ですが以前、サクラエディタをインストールしてからいざ正規表現を使おうとしたときに「bregonig.dllのロードに失敗しました」と表示されて正規表現が使えないことがありました。

未経験でも安心!人気のプログラミングスクール

マンツーマン指導だから未経験からプログラミングが学べて高いコーディングスキルが身につく人気のテックキャンプ!

インストールパッケージじゃないと正規表現使えない?

サクラエディタの「インストールパッケージ」には、正規表現モジュールがありそのまま正規表現が使えます。

ですがこの正規表現モジュールはZIP版には含まれていないようです。

僕はZIP版でインストールしたために正規表現が使えませんでした。

正規表現のモジュールがあるか確認する

正規表現のモジュールが追加されているかされていないか確認したい場合は下記になります。

まずがサクラエディタを開きます。

そして上にある「検索」→「検索」をクリックします。

開かれたダイヤログから正規表現の横にモジュール名やバージョンが記載されている場合は正規表現が使えます。

ですがもしない場合は正規表現のモジュールをインストールする必要があります。

regonig.dllをインストールする

サクラエディタで正規表現を使うためには「regonig.dll」をインストールする必要があります。

インストールは下記のページからできます。

上にあるダウンロードから最新をインストールしましょう。

コメント

タイトルとURLをコピーしました